-天気予報コム-

Flag counter

« 2016年11月 | トップページ

2017年7月

PoderosaでOpensshサーバへ接続した際に「Server does not support diffie-hellman-group1-sha1 for keyexchange」とエラーが出る問題

SSHクライアントアプリであるPoderosaでopensshサーバに接続した際に「Sercer does not support diffie-hellman-group1-sha1 for keyexchange」とエラーが出て接続出来ない問題の対応メモです。

<症状>
opensshへ接続時に以下のようなエラーが出る。同じopensshサーバに接続する場合でもteraterm等だと出なかったり、他のバージョンのopensshサーバに接続する場合は出なかったりする。

2017070601_poderosa_error

<発生環境>
自分の所で使用していたPoderosaは4.3.10bでした。

2017070602_poderosa_error


<原因>
結論から言うと、Poderosaのバージョンが古いためにopensshサーバ側が要求する鍵交換アルゴリズムに対応していないのが原因です。


<対策>
Poderosaの最新版を使用して下さい。2017/07/06時点では.4.4.0-devが最新版でした。
https://sourceforge.net/projects/poderosa/

2017070603_poderosa_error


ちなみにこの問題はBeagle Bone BlackにインストールしたUbuntu 16.04LTSのsshdに接続して問題が発生しました。

« 2016年11月 | トップページ

無料ブログはココログ
2017年7月
            1
2 3 4 5 6 7 8
9 10 11 12 13 14 15
16 17 18 19 20 21 22
23 24 25 26 27 28 29
30 31